Jump to content
Alex_prom

Рассинхрон по времени у потоков с камеры.

Recommended Posts

Здравствуйте!

image.thumb.png.3807e8d4c3be28ce875a30b10b3445e5.png

На картинке видно разницу по времени между двумя потоками примерно 10 минут.

Рассинхрон устраняется  перезагрузкой камеры. 

Эта разница набежала за 5 часов.

В веб-интерфейсе камеры стоит синхронизация времени с ПК.

Доступа в инет для синхронизации со службой  времени камеры не имеют.

Что посоветуете устранения подобного перекоса?

Share this post


Link to post
Share on other sites

Здравствуйте !
Как правило, причина в использовании H.265+
Если он не используется, необходимо обеспечить доступ к серверу или к ПК в одной LAN с регистратором с помощью программы TeamViewer (7/8/9 версии)  https://devline.ru/soft/tv.exe . Данные укажите личным сообщением.

Share this post


Link to post
Share on other sites

На проблемных камерах  используется  только H.264+.

Попробую настроить синхронизацию по времени с контроллером домена.

Если снова ничего не получится, тогда свяжемся по TeamViewer .

Share this post


Link to post
Share on other sites

Здравствуйте.

1 час назад, Alex_prom сказал:

В веб-интерфейсе камеры стоит синхронизация времени с ПК.

Доступа в инет для синхронизации со службой  времени камеры не имеют.

+

37 минут назад, Alex_prom сказал:

Попробую настроить синхронизацию по времени с контроллером домена.

Синхронизация времени на устройствах никак не влияет на данный параметр, так как оба "временных таймера" берутся с одного сервера - к которому камера подключена.

Вся проблема в буферизации потока, как-то неадекватно она работает:

1. Либо, как и говорит Станислав, проблема с выбором кодека. Тем более, на некоторых камерах H.264+ может являться кодеком H.265. При версии Линии до 7.7.0 включительно с H.265-кодеком она не работает.

2. Либо камера формирует поток H.264+ так, что Линия не успевает его обрабатывать.

3. Либо сервер загружен на столько, что обрабатывать не успевает.

4. Либо иные ресурсы загружены на столько, что проблемы возникают при передаче потока (сеть, жёсткий диск).

 

Надо пробовать:

1. Сменить кодек.

2. Обновить прошивку камеры.

3. Обновить Линию (кстати, версия какая установлена?).

4. Проверить стабильность работы сервера.

5. Проверить стабильность работы сети.

6. Проверить стабильность работы жёстких дисков.

 

ПС. Раньше (с момента подключения камеры) такая проблема возникала? Или появилась недавно?

И менялось ли что-то в этот период?

Edited by unlifer

Share this post


Link to post
Share on other sites

Здравствуйте!

15 минут назад, unlifer сказал:

2. Обновить прошивку камеры.

3. Обновить Линию (кстати, версия какая установлена?).

Прошивку первым делом обновил при обнаружении проблемы.

Версия везде 7.7.0_x64.

Сейчас оставляю на всех проблемных камерах только H.264.

17 минут назад, unlifer сказал:

4. Проверить стабильность работы сервера.

На одном сервере, даже на однотипных камерах, на некоторых камерах есть рассинхрон, другие работают стабильно. 

Возможно рассинхрон идет из-за того что некоторые камеры просматривают чаще, (охрана, руководство, архив),  а некоторые не интересны, и на них все нормально со временем.

20 минут назад, unlifer сказал:

Раньше (с момента подключения камеры) такая проблема возникала? Или появилась недавно?

Возможно это было всегда, обнаружили относительно недавно.

Share this post


Link to post
Share on other sites
1 минуту назад, Alex_prom сказал:

Сейчас оставляю на всех проблемных камерах только H.264.

 

Хорошо.

Сообщите, пожалуйста, о результате.

Share this post


Link to post
Share on other sites
8 минут назад, Alex_prom сказал:

На одном сервере, даже на однотипных камерах, на некоторых камерах есть рассинхрон, другие работают стабильно. 

Возможно рассинхрон идет из-за того что некоторые камеры просматривают чаще, (охрана, руководство, архив),  а некоторые не интересны, и на них все нормально со временем.

А запись в архив случайно не настроена по группам камер для записи? Может проблемные камеры как раз в одной группе находятся?

Кодек на беспроблемных камерах тоже H.264+?

Edited by unlifer

Share this post


Link to post
Share on other sites
1 час назад, unlifer сказал:

А запись в архив случайно не настроена по группам камер для записи? Может проблемные камеры как раз в одной группе находятся?

Не, эта причина маловероятна, т.к. даже на 8 канальном регистраторе с одним  жестким диском 6 камер ок, а на двух рассинхрон.

 

1 час назад, unlifer сказал:

Кодек на беспроблемных камерах тоже H.264+

 

Везде по разному.
Но на проблемных камерах был везде включен H.264+
Есть камеры с включенным H.265+ без рассинхрона, но эти камеры еще не выведены никуда, их никто не сморит, пока только идет запись с них.

Сейчас на всех проблемных оставляю только H.264.  
Утром посмотрю что получилось, обычно за ночь минут на 20-40 рассинхронизировалось.

Share this post


Link to post
Share on other sites
18 часов назад, Станислав сказал:

Сообщите, пожалуйста, о результате.

 

По результатам работы за ночь на проблемных камерах рассинхрон исчез. 

Но требуется более длительное наблюдение.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×