Jump to content

Recommended Posts

1й поток 1920х1080 при 12 fps , проблем никаких

https://drive.google.com/file/d/1459XqBcqa_bL2G4LHxvYIbgTTv93QojK/view?usp=sharing

 

2й поток 704х576 при 12 fps ведет себя крайне неадекватно

https://drive.google.com/file/d/1HYoq-DWlmMccwc2UsvPqr9XV1HPQOZ7E/view?usp=sharing

Кто с таким сталкивался, куда копать?

Share this post


Link to post
Share on other sites

Здравствуйте !
Попробуйте сбросить настройки потоков IP камеры на заводские.
Попробуйте увеличить битрейт и количество опорных кадров.  
Прикрепите скриншоты настроек потоков, укажите модель камеры и версию прошивки.

 

Share this post


Link to post
Share on other sites

камера Matrix MT-DW1080IP20SE-M DC

Производителю тоже отписался, но они раньше понедельника не отзовутся.

Проблема началась когда было 20 fps, скинул до 12, ситуация не поменялась. С опорным кадром тоже пробовал.

Непосредственно поток вручную указать не дает. Только сама его меняет в зависимости от заданного качества (good, better, best)

Проблема не постоянная, порой все замечательно работает.

Прошивка? Но ведь пару месяцев жалоб не было.

 

 

версия.PNG

настройки.PNG

Share this post


Link to post
Share on other sites

Audio у второго потока отключите.
Сбрасывать к заводским настройкам пробовали?
Если Вам требуется удаленная помощь, необходимо обеспечить доступ к серверу с помощью программы TeamViewer (7/8/9 версии)  https://devline.ru/soft/tv.exe Данные для подключения укажите  личным сообщением.

Share this post


Link to post
Share on other sites

Здравствуйте.

А почему опорный кадр равен 2? Это же не нормально, рекомендуется вдвое большее значение, чем частота кадров, то есть при 12 к\с должно быть для опорника 24 стоять значение.

Или это множитель для опорного кадра и указан?

Показывает плохо и в архиве, и онлайн?

Превысить общий FPS или битрейт для регистратора не могли?

Не добавлялись ли камеры за эти два месяца или количество подключаемых клиентов?

На самой камере, через веб-интерфейс, то же самое со 2-м потоком или нет?

Share this post


Link to post
Share on other sites
9 часов назад, unlifer сказал:

А почему опорный кадр равен 2?

А ведь вы заставили меня задуматься.

На некоторых камерах настройка называется GOP(F) это есть число кадров между опорниками, соответственно при 12 к/с и GOP(F) = 24 получим один опорный каждые 2 сек. Тут же i frame interval. Выбор тут целое число от 1 до 12. Я рассчитывал, что это один опорник в две секунды. Если же эта логика что и в первом случае, то даже при 25 к/с  получим, что между опорными кадрами максимум 12, что как-то совсем недостаточно. 

9 часов назад, unlifer сказал:

Показывает плохо и в архиве, и онлайн?

Печально в онлайне, кадр разваливается, движущиеся объекты размазываются, периодически Нет сигнала, потому и решил записать второй поток, поглядеть как оно там. Но в архиве часть этих дефектов не видна, просто кадр останавливается. 

9 часов назад, unlifer сказал:

Превысить общий FPS или битрейт для регистратора не могли?

Не добавлялись ли камеры за эти два месяца или количество подключаемых клиентов?

Схема простейшая: роутер, в него воткнуты две ip камеры и пк, который выполняет роль видеосервера с 4х канальной платой. К роутеру еще телефон цепляется периодически. Вторая камера чутка другой модификации без встроенного микрофона, с ней проблем никаких. Эта же начала капризничать. Иногда работает. Иногда второй поток застревает, обрывается. Иногда и первый так же себя ведет. Линия в логах периодически регистрирует потерю сигнала. Причем в моменты глюков камера продолжает пинговаться.

 

9 часов назад, unlifer сказал:

На самой камере, через веб-интерфейс, то же самое со 2-м потоком или нет?

Через VLC по RTSP ссылке ситуация та же, через веб-интерфейс не проверял.

 

 

Share this post


Link to post
Share on other sites

Здравствуйте !
Теста через VLC достаточно.
1.) Audio у второго потока отключили?
2.) Сбрасывать к заводским настройкам пробовали?
3.) Попробуйте исключить сеть и питание камеры.

Share this post


Link to post
Share on other sites
1 час назад, Станислав сказал:

1.) Audio у второго потока отключили?

да

1 час назад, Станислав сказал:

2.) Сбрасывать к заводским настройкам пробовали?

да

1 час назад, Станислав сказал:

3.) Попробуйте исключить сеть и питание камеры.

обе камеры подключены идентично. Порты на роутере перетыкал.

Share this post


Link to post
Share on other sites

В таком случае необходимы комментарии технической поддержки производителя камеры по вопросу рассыпания RTSP потока в VLC 

Share this post


Link to post
Share on other sites
Posted (edited)

Попробуйте исключить из этой схемы, хотя бы временно, роутер - воткните кабель от камеры в сетевуху компа. Возможно, роутер не вывозит поток по данному порту \ по данной камере.

И, кстати, если речь идёт о сервере с платой видеозахвата, то могу предположить, что комп на Windows. И есть подозрение, что кодек H.265X - лишний. Попробуйте другой, например, H.264.

Ещё было бы не плохо знать последняя прошивка на камеру стоит или нет?

Edited by unlifer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×