Jump to content

Recommended Posts

Вопрос не к Девлайну даже, но к более опытному сообществу

Камера Matrix mt-dw1080ip20 с матрицей 1/2.8" Sony 2.1MP

Движущиеся объекты размазываются, на долю секунды замирают, такое ощущение, что теряются кадры

Какие настройки крутить, чем можно поправить?

само видео на гугл диске, 35 МБ

https://drive.google.com/open?id=159Fb1qKoaAtIdpiDTQzCO1BQFB9xBf0s

 

Снимок2.PNG

Снимок.PNG

Share this post


Link to post
Share on other sites

Здравствуйте !
Попробуйте обновить прошивку камеры и сбросить настройки на дефолтные.
Установите GOP (опорный кадр) на камере не реже чем раз в 2 секунды.
Если не поможет,  попробуйте исключить сеть  - соберите тест "на столе" использую другое сетевое оборудование

Share this post


Link to post
Share on other sites

камера как подключена???

кабель или вай фай?

Share this post


Link to post
Share on other sites

Провод. Первым делом бы исключил вифи, если бы он был, конечно.

Трасса короткая, метров 15-20. Пинг стабильный 1 мс, пакеты не теряются. На данном коммутаторе висят еще три других камеры и с ними проблем нет. Но те камеры с другой начинкой, хоть интерфейс и настройки одинаковые, но не показатель. Вообще их отключил, оставив лишь одну проблемную и сервер. Поведение никак не изменилось.

Склоняюсь что вина тут все же в самой камере, ее настройках или же прошивке. Отписал производителю.

 

 

 

Share this post


Link to post
Share on other sites

Попробуйте воспроизвести RTSP ссылку камеры в VLC (Медиа - Открыть URL) плеере и посмотрите есть ли потери кадров (Инструменты - Информация о кодеке). 

На WEB интерфейсе можно попробовать поизменять следующие параметры: Coding level  и Quality.

Если камера поддерживает ONVIF, то через программу Onvif device manager можно попробовать понастраивать кодирование, возможно есть отклонения от WEB интерфейса.

Со стороны ПО Линия в настройках можно попереключать TCP\UDP при подключении камеры. Если это всё не поможет, тогда только ждать новой версии ПО Линия 8.0 (там и серверное ядро и  клиентская часть будут переработаны и оптимизированы на работу с "выпадающими" кадрами).

 

 

Share this post


Link to post
Share on other sites
56 минут назад, Садов Антон сказал:

Попробуйте воспроизвести RTSP ссылку камеры в VLC  плеере и посмотрите есть ли потери кадров

Пробовал. Потерянные кадры проскакивают, но они не совпадают с происходящем на экране.

 

58 минут назад, Садов Антон сказал:

Coding level

Пробовал все три: baseline, main profile, high profile

так и не понял на что конкретно влияет этот параметр.

1 час назад, Садов Антон сказал:

Quality

тут ситуация интереснее, при установке 4 Mbit/s и 20 к/с, камера выдает лишь 15-17. При 3  Mbit/s даржатся указанные 20 к/с но иногда бывают просадки до 15-17. Опять же они никак не соотносятся с происходящем. Просадки могут быть когда движущихся объектов вообще нет.

 

1 час назад, Садов Антон сказал:

можно попереключать TCP\UDP

Тоже уже пройденный этап.

----------------------

Свежая прошивка от производителя получена. Проблема решена.

 

Share this post


Link to post
Share on other sites

 Здравствуйте!

Спасибо что сообщили результате

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×