Jump to content
GrigorevMikle

Тормозит при записи и отображении

Recommended Posts

Другой объект

2)В данный момент загруженность АРМ Сервер

ОП - Занято 1,9 Свободно 6100мб

ЦП - 28% занято

Сеть - 40-50% занято

Тормозит при записи и отображении в чем проблема?качество картинки практически минимальное,это решено одним потоком то есть на запись и просмотр,если потоки разделить это улучшит ситуацию?

Edited by GrigorevMikle

Share this post


Link to post
Share on other sites

Здравствуйте!
Как правило,  причина подобного поведения или в настройках/прошивках IP камер или в камерах (питание/перегрев) или в нестабильности сети/проблемах с сетевым оборудованием. Попробуйте подключить RTSP ссылками (ссылки можно посмотреть на вкладке "Информация" в самой "Линии") .   Проконтролируйте параллельно стабильность потока с этих же ссылок в VLC. VLC можно с этого сайта http://www.videolan.org/vlc/index.ru.html , после установки и запуска нажмите "Медиа" - "Открыть URL" - "Сеть" и вставив RTSP ссылку в поле нажать "Воспроизвести".

Если в VLC поток качественный, а в "Линии" разительно отличается,  нужен  удалённый доступ к серверу с помощью ПО TeamViewer 8|9 ( www.devline.ru/soft/ds.exe ) - укажите данные для подключения личным сообщением.

Share this post


Link to post
Share on other sites
Цитата

Сеть - 40-50% занято

Судя по загрузке сети, у Вас настроено на камерах MJPEG-кодирование и сеть не справляется.

На сервере 100 Мбит\с или 1000?

Цитата

ЦП - 28% занято

Судя по загрузке ЦП, сервер справляется в целом, но лучше перевести на RTSP-ссылки, H264-кодирование и с подключением второго потока с камер.

Цитата

Тормозит при записи и отображении в чем проблема?

Скорее всего, в сети в данном случае. Правда, не стоит и исключать работу дисков под архив.

Цитата

если потоки разделить это улучшит ситуацию?

При MJPEG-кодировании может стать ещё хуже. При H264-кодировании можно как сделать хуже, так и гораздо лучше.

Я бы посоветовал:

1. Включить на камерах RTSP поверх HTTP.

2. Перевести 1й поток на H264.

2.1. Выставить нужное разрешение, частоту кадров, битрейт для хорошей картинки.

3. Включить на камерах 2й поток и тоже H264.

3.1. Выставить битрейт в 256, частоту кадров до 8, разрешение в CIF.

4. Подключить камеры в Линии RTSP-ссылками.

5. Включить запись 1го потока, выключить запись 2го и 3го потоков.

Внимание! Ни в коем случае не надо делать вперемешку, то есть 1\3 камер MJPEG + второй поток, 1\3 камер с перекодированием в Линии, 1\3 камер H264 + второй поток или перекодирование. Всё должно быть однотипно, тогда и будет стабильность. Иначе будет загрузка ЦП от 80 до 100%.

Share this post


Link to post
Share on other sites
2 минуты назад, unlifer сказал:

Внимание! Ни в коем случае не надо делать вперемешку, то есть 1\3 камер MJPEG + второй поток, 1\3 камер с перекодированием в Линии, 1\3 камер H264 + второй поток или перекодирование. Всё должно быть однотипно, тогда и будет стабильность. Иначе будет загрузка ЦП от 80 до 100%.

Вот это не верно.

Цитата

Судя по загрузке сети, у Вас настроено на камерах MJPEG-кодирование и сеть не справляется.

Сколько камер не указанно, а загруженность сети в 50% вполне приемлемая.

Цитата

Судя по загрузке ЦП, сервер справляется в целом, но лучше перевести на RTSP-ссылки, H264-кодирование и с подключением второго потока с камер.

Загрузка в норме, а MJPEG  или H. 264 - не важно.

Цитата

Скорее всего, в сети в данном случае. Правда, не стоит и исключать работу дисков под архив.

HDD пока в сторону. Если проблема с сетью  - можно попробовать в настройках  в настройках "Линии" для данной камеры переключить с UDP на TCP.  Ну лучше для начала найти причину.

Share this post


Link to post
Share on other sites
Цитата

Вот это не верно.

Не знаю есть ли у Вас подобного рода стенд, но у меня не то что стенд, а сервер такой стоит на 31 камеру (сейчас уже 28). По началу всё работало на этом сервере под Debian на Avreg с MJPEG и одним потоком (11 камер 1080p, 20 камер D1, но на первых разрешение выставлено было на 960H, затем 720p, на вторых VGA, выше софт не позволял), всё было относительно хорошо и стабильно (ЦП 30-40%, сеть примерно 10-20%, потери пакетов в сети не более 1%).

Руководство решило перевести сервер на Линию. Загрузка ЦП чуть подросла, при выставлении разрешения в 1080p выросла ещё больше, до 60-70% при одном потоке в MJPEG + жуткие тормоза на клиентских ПК (вплоть до прогрузки вида в 31 камеру в течение минуты-двух) + постоянно вылетающая надпись на камерах "Нет сигнала" + постоянно вылезавшая надпись на клиентах при выходе из админки "Сохранение видов". При двух потоках (что перекодирование в Линии, что вперемешку- где с камер, где перекодирование) картина была ещё более удручающая.

Так было пока: сеть не стала расширяться, все сервера не переехали в одну серверную, в определённом сегменте сети не добавилось ещё 30 камер на 2-4 Мп. Вот тут и начались большие потери в сети + стали всплывать артефакты в видео. Соответственно стал переводить все камеры на H264 + второй поток, но всплыли другие проблемы:

1. одни камеры при 2м потоке выдают немаксимальное разрешение на 1м, соответственно на них настраивался только один поток H264  + перекодирование 2го потока в самой Линии, при одном потоке в Линии загрузка ЦП была ещё более значительной,

2. другие камеры на столько старые, что при захвате 1го и  2го потока с них - они стали просто отваливаться, потери пакетов до каждой такой камеры в 70-90%, хотя до соседних камер без перенастройки на том же коммутаторе сеть стабильная 0% потерь, при возврате к захвату только 1го потока, потери исчезали. Опять же, с камер 1й поток H264 + перекодирование в самой Линии,

3. есть камеры, на которых вообще или только один поток и только MJPEG, или переключаешь на H264, но настройки не сохраняются (в принципе, на них вообще 70% настроек сейчас не сохраняется - на столько старые, им в утиль пора), то есть с них только MJPEG + перекодирование в самой Линии, при одном потоке загрузка ЦП более значительная,

4. несколько новых камер (если быть точным, то 4) взамен вышедших из строя, с которых и 1й, и 2й потоки забираются в H264.

При переводе, так сказать, условно на H264 загрузка ЦП 80-90% сеть 2-10%. Убрал "лишние" зоны детекции - выставил на всё изображение одну - загрузка ЦП 60-70%. Зато другие проблемы ушли сами (то есть выше упомянутые: жуткие тормоза на клиентских ПК (вплоть до прогрузки вида в 31 камеру в течение минуты-двух) + постоянно вылетающая надпись на камерах "Нет сигнала" + постоянно вылезавшая надпись "Сохранение видов" на клиентах при выходе из админки).

При обновлении Линии до 7.4.0 загрузка ЦП выросла до 98-100%.

Настроил второй поток так, как посоветовал пользователю GrigorevMikle, хотя бы на тех камерах, где второй поток всё таки работает (буквально 5-10 камер) + старьё всё таки перевёл на H264 (изрядно повозился и весь изматерился :) ) + понизил частоту кадров на старье до 12 = загрузка 80-85%. Вот подумываю снизить ещё частоту кадров до 8 на 1м потоке на старых камерах, чтобы сервер вздохнул с облегчением. А то может и на 1080p-камерах снижу до 12.

Цитата

Сколько камер не указанно, а загруженность сети в 50% вполне приемлемая.

А если скорость подключения в 100 Мбит\с? Имхо, это не вполне приемлемо. У меня на серверах средняя загрузка сети 5% при гигабите. Вроде, что там что тут 50 Мбит получается, но запас в 50 и в 950 абсолютно разные цифры.

Но даже если скорость гигабит, то 50% от гигабита - это явно не хорошо сети. Это если только торрент на все деньги на сервере включили + биткоины майнят :)

Даже если количество камер не указано, то 50% много. При 20-30 камерах на "моих" серверах загрузка средняя 5%. А если загрузка в 50% при нескольких камерах, то это явно нестабильная работа.

Share this post


Link to post
Share on other sites

Не об этом речь, Вы не верно сформулировали, поэтому я и написал, что это не верно.

Цитата

Внимание! Ни в коем случае не надо делать вперемешку........ Всё должно быть однотипно, тогда и будет стабильность. Иначе будет загрузка ЦП от 80 до 100%.

Прямой взаимосвязи между "делать вперемешку" и  " будет стабильность " и "будет загрузка ЦП от 80 до 100%" - нет.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×