Jump to content
Павел М

RVI-IPC33M нет звука

Recommended Posts

Добрый день, установили на объекты камеры RVI-IPC33M. Установили ПО Линия 6.9.6. Появились проблемы:

1) Картинка на камерах постоянно зависала и рассыпалась.

2) Автополучение ссылки на звук не работало.

Что сделано:

1) Свич замнен со 100-мегабитного на гигабитный, что вылечило первую проблему (хотя загрузка кнала не привышала 30%)

2) Созвон с техподдержкой ПО Линия и RVI групп.

Поддержка ПО посоветовала обратиться за RTSP ссылкой к производителю.

Поддержка RVI выдала RTSP ссылку :  rtsp://username:password@192.168.3.6:554/cam/realmonitor?channel=1&subtype=0

и предложила проверить работоспособность звукового канала с помощью VLC медиаплеера.

Результаты: в указанном плеере видео идет со звуком как на 1 так и на 2 канале. При установке получения звука в настройках камеры в положение RTSP  и копирование туда выданной производителем ссылки к появлению звукового потока не привели.

-звук в настройках включен

-IP адрес в ссылке изменялся соответственно с настройками камер.

-настройки применены

 

Как получить звуковой поток с данной камеры в ПО Линия?

 

Share this post


Link to post
Share on other sites

Здравствуйте Павел!
Нужен удалённый доступ к камере (оптимальный вариант)  или к серверу "Линии", например с помощью ПО TeamViewer 7|8 (www.devline.ru/soft/ds.exe), если это возможно,  укажите данные для подключения личным сообщением.
Если не возможно, пришлите, пожалуйста, сбор  сведений о системе, сделанный с помощью Линии ("Пуск\Все программы\Линия 6.9.6\Сбор сведений о системе") и максимум скринштов из VLC (Инструменты = > информация о медиафайле) и "Линии". Попробуйте её принудительно подключить по ONVIF.

Share this post


Link to post
Share on other sites

Спасибо за предоставленный доступ.

Для примера настроил вторую камеру. Обратите, пожалуйста, внимание на настройку второго потока и битрейта. 

Если у Вас возникнут вопросы, мы постараемся на них ответить.

Share this post


Link to post
Share on other sites

спасибо за помощь, правильно ли я понял что при не явным образом указанном битрейте не хватало ширины канала?

Share this post


Link to post
Share on other sites

Нет, не верно, на данных камерах могут появятся артефакты.

Share this post


Link to post
Share on other sites

расскажите подробнее как получили звук.

 

у меня такая же проблема, за исключением того, что сначала все работало.

подцепил звук по RTSP, все завелось с первого раза безо всяких бубнов, но спустя пару месяцев просто перестал идти звук в Линию. никаких прошивок, программ не обновлял. 

с веб интерфейса камеры и в VLC звук есть.

Share this post


Link to post
Share on other sites

Мужики, извиняйте, не заметил, что каким-то образом в настройках камеры изменились номера портов, на какие-то нестандартные,

очень странно. вернул как должно быть, все пошло.

 

замечено, что при подключении RVI камер по UDP картинка сыпется если камер несколько, ставим TCP, и все идет нормально, но при подключении по TCP линия меняет в камере настройки портов (их номера) и звук отваливается, меняю порты на стандартные (по умолчанию) и все идет, но после нескольких секунд линия снова меняет номера портов в камере и звук опять слетает, поэтому на камерах со звуком ставлю UDP, на тех, что без звука TCP.

 

 

и еще один момент в настройках камеры частоту звука надо ставить 8К, если оставить 16К, как по умолчанию, звук получается как из ****, хотя в том же VLC все в порядке на любой частоте

Share this post


Link to post
Share on other sites

Здравствуйте!
"Линия" не может менять порты на самих камерах
Пришлите, пожалуйста, сбор  сведений о системе, сделанный с помощью Линии ("Пуск\Все программы\Линия 6.9.6\Сбор сведений о системе").
Если к серверу возможен удалённый доступ  с помощью ПО TeamViewer  (www.devline.ru/soft/ds.exe) - укажите данные для подключения личным сообщением.  Ещё лучшим вариантом будет доступ к самой камере.

Share this post


Link to post
Share on other sites

Такая же беда. Как включаю микрофон, треск в колонках и всё. Звука нет. Делаю на камере Частоту 8. Камеры работают по rtsp ссылке. Может надо прописать такую же ссылку для звука? У меня стоит Автополучение ссылки. Подскажите формат rtsp ссылки или что сделать?

Share this post


Link to post
Share on other sites

Здравствуйте!
1. Камера RVI-IPC33M?
2. Версия ПО "Линии" актуальная? Попробуйте обновить программное обеспечение до версии http://devline.ru/f/linia-6.9.6-62bc3849851a-ru.exe без сохранения логов и информации об ошибках.
3. Звук для обоих потоков включен? Попробуйте указать для звука  ссылку rtsp://username:password@ip_address:554/cam/realmonitor?channel=1&subtype=0
4. Если  принудительно подключить по ONVIF, звук есть?
5. В веб интерфейсе камеры звук работает нормально?
6. Если к серверу возможен удалённый доступ  с помощью ПО TeamViewer 8|9 (www.devline.ru/soft/ds.exe) - укажите данные для подключения личным сообщением
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×