Jump to content
Bege

Отстает звук через веб и айпад

Recommended Posts

Звук в вебинтерфейсе и на айпаде сильно отстает от видео(2-3 секунды). Что-то сделать можно ?

 

Версия софта - 6.7.4

 

Камера и микрофон аналоговые.

Edited by Bege

Share this post


Link to post
Share on other sites

Здравствуйте!

Проверяем.

Уточните модель iPad, версию iOS, пропускную способность канала сервер<->клиент, присутствие/отсутствие потерь пакетов.

Share this post


Link to post
Share on other sites

iPad 2, iOS 6, (так же тестировали на ipad3, iOS 5) айпад законекчен по wi-fi к точке доступа (100% сигнал), точка доступа по ethernet к свичу, на этом же свиче сидит видеосервер.

 

Так же звук отстает в веб-интерфейсе через любой браузер, компьютер с броузером в том же свитче что и сервер.

 

Потерь пакетов нет.

Share this post


Link to post
Share on other sites

Здравствуйте!

Спасибо за предоставленную информацию!

Видимо, речь всё же идет об отставании звука определённого размером буфера. Возможно, в следующих версиях включение/отключение буфера будет опционально, что позволит полностью убрать данный эффект в LAN.

Share this post


Link to post
Share on other sites

Попробуйте распаковать и заменить файлы buf_flash.zip в папке C:\Program Files\DevLine\Linia SKW\www

Не помогло. Поигрался с secBufLoad в index.html, но ни на что не повлияло.

Share this post


Link to post
Share on other sites

Перезапустите службу devline kernel после замены файла

Share this post


Link to post
Share on other sites

Как-то странно. Службу перезапускал после изменения файлов. Потом решил уж компьютер рестартануть.

 

 

Но после перезагрузки компьютера веб-интерфейс не работает. Просто белый экран. Посередине написано Error in flashvars. Причем написано белыми буквами на белом фоне)) Заметил чисто случайно, проведя мышкой по центру экрана курсор сменился как будто он на текстовом поле.

Share this post


Link to post
Share on other sites

Задержка в вебе снизилась где-то до 1-2 сек., на старом варианте 2-3сек. И кстати качество видео упало, переключатель качества min-max не работает.

 

 

В айпаде ничего не изменилось.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×